Saving in ViewMate Deluxe

Need Help? Ask your questions here.

Saving in ViewMate Deluxe

Postby dakine001 » Sun Jul 11, 2010 11:15 am

Hi:
I am using VMD to make corrections to my gerber files, generated from P-CAD 2002. In P-CAD, when I export to gerber, I have my Output Units to INCHES, Numeric Format to 4.4 and select RS-274X Style Output.

In VMD, I import my gerber layers (since in P-CAD, I generate gerbers according to their layers and use file their extensions to distinguish between them (i.e. .TOP, .BOT, .PWR, etc.)). I usually get a warning message, "Coordinate block without a D command: D42* X38920Y32251* D2 will be assumed." but everything imports fine and I do my modifications and then try to save.

Now I tried SAVE, SAVE AS, SAVE BY, SAVE OPTIONS and EXPORT. I can appear to save my files as they originally came in. I was saving using EXPORT => BASIC GERBER... (Layer by Layer). I thought this is ok until I opened the save file and the P-CAD gerber file together. The VMD gerber file was located in a different XY coordinate dimension and the entire file was also resized by 100.

Can anyone explain what is going on here and how to save correctly. Thank you.
dakine001
 
Posts: 2
Joined: Sun Jul 11, 2010 10:58 am

Re: Saving in ViewMate Deluxe

Postby marius » Sun Jul 11, 2010 7:09 pm

First, let me point out that there is a manual available for download:
ftp://ftp.pentalogix.com/Documents/CAMGuide.pdf
It has been written a while back and it is a bit out of date, but, you can find info for the basic operations, like import and export. Those have not changed a lot since the manual was written.
First a note about the warning that you mention. It is because of ambiguous syntax in the Gerber file that you are importing. "D42* X38920Y32251*" means that you pick a new aperture (number 42) and then comes a block with only X and Y coordinates and no D field. In Gerber the D field is used for both changing apertures and specifying the type of operations:
D3 is "flash a pad"
D1 is "draw to this point" and
D2 is "move to this point"
Your block has no D command. We assume "D2" (move) which is usually the correct guess, but we want to let the user know that there was something ambiguous in the file.

As for outputting a Gerber file, the command you want is "File/Export/Gerber Extended". Gerber Extended includes a header with info about D Code shapes and also the format of the file (4.4 etc). Basic Gerber has no such header and so you need to set the parameters manually when you import such a file.

For exporting Gerber Extended there is an "Options" button at the bottom of the dialog and you will need to use it to set up the kind of files that are generated. If you want to match the same parameters as in your input, please set as below:

Snap1.gif


If you pick "Layer by layer", the layers that you pick will be saved to file names given by the layer names. This may overwrite your original files. If this is not what you want, you can change the layer names using the "Setup Layers" dialog. You can also pick "Combined" in which case you can give the new name of the file in the export dialog box. This will however export all the layers you picked into one file, so if you want to use this method, pick one layer only for each "Combined" export.
You do not have the required permissions to view the files attached to this post.
marius
 
Posts: 179
Joined: Tue Dec 01, 2009 10:25 am

Re: Saving in ViewMate Deluxe

Postby dakine001 » Sun Jul 11, 2010 10:14 pm

Thank you Marius. I will try your suggestions.
And yes, I did read the save portion of the CAMGuide. But I couldn't find a reason why
the file was scaled by 100.
Thank you again.
dakine001
 
Posts: 2
Joined: Sun Jul 11, 2010 10:58 am


Return to Support Q&A for ViewMate

Who is online

Users browsing this forum: Bing [Bot] and 1 guest